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EDSGN 496A: SolidWorks

Fundamentals

SKETCH: The Designh Environment
Introduction, Objectives, and Goals
User Interface

Associative Design

Design Intent & Constraints
CommandManager: Sketch & Features
Extruded Base

Basic Strategy
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h ° | Mission Statement

Students should be proficient in
communicating and analyzing
designs as 3-D models.
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Certificate of Achievement 7_;;
SolidWorks

we congratulate you on your achievement

Randall Bock

has completed the requirements for:

Certified SolidWorks Associate

K. AT T ==
. . Jeff Ray | CEO, Dassault Systémes SolidWorks Corporation Certificate ID: C-9RPRCJTJMY
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HaPPY VALLEY

| SolidWorks
: LUSER GROUP
PEMNMNSTATE

o e Happy Valley SolidWorks User Group

Dmmi. TECHHOLDSET, AMD
FPrDr keRCRAL PHOCSA M

G

Haorme Our MiSSiOn:

« The HVYSWIUG is a networl of
academic and industrial resources
dedicated to advancing the 3D
CAD educational experience.

Prewvious Everts

viembers

Local Infarmation

« Group meetings feature technical
presentations in engineering design
and analysis using Solidyorks.

Sp g

Contact L=




jﬂéﬁm . Pedagogy

- Instructive theory

- Trainee teachers learn their subject and also the
pedagogy appropriate for teaching that subject.




ji“!%ﬁm e Andragogy

- The art and science of teaching adults.
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. SolidWorks Simulation

The Design Cycle

Finite Element Method
SolidWorks Simulation
Defining a Simulation Study
Controlling the Mesh
Accessing the Results
Indentifying Singularities
Instructional Examples

Tips and Tricks
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wﬁ"" A Traditional Design Cycle

. Build a 3D model. [SO"dW"rkS “—‘

- Manufacture prototype.

¢

Prototype ]

- Test the prototype.

- Analyze results
= modify the model

= puild a new prototype

No

Satisfied?

= test it again

= repeat

Virtual Prototyping of Hydro pneumatic
Suspension system
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o FEA Integrated Design Cycle

[ SolidWorks ]H

A

Satisfied?

l Yes

[$ Prototype ]

< No Test




s i TR Lt s N TS e : g ' " F - 9¥F -~ P o i, T e, SR Pt R T o AL R
g T WAy :"‘_“ ~ 2 M.. : LT . - ,"‘ Ay 118 L o m\ i LI [ o ‘.‘_L}ﬁ ?’E‘h
- - S 4 --,E

mo _ _ Tools > SimulationXpress
vt SimulationXpress

@
« Limitations

1. PARTs (one solid body)

2. Static analysis only (stress)

3. Optimize one variable

4. Isotropic materials RO
5. Uniform loads 54 COSMOSXpress wa COSHOSress com
6. Fixed restraints K O B O W

YWelzome to COSMOS=presz. Thiz deszign analyziz wizard guides you step-by-ztep
to determine how vour designg will perform under certain conditionz. |F can help
wou answer tough engineenng guestions lke;

Wil the part break?

Huoow waill it deform’?

Can | uze lezs material without affecting performance?
Thig iz a tool to provide ztress analyziz early in the design cycle to catch potential
problems before extenzive work haz been done. Most analysiz problems will require
a comprehenszive analysiz product for maore accurate and complete real waorld
zimulationg before final sign-off on a design.

Start Owver | | Dptiuns.‘..l

<Back | Nest> | Close | Cancel | Help |




S e o R /R e
mo _ _ _Tools > Add-Ins
o SolidWorks Simulation

- Advantages
= Parts & Assemblies
= Non-linear, thermal, buckling, frequency, drop test,
optimization, fatigue x|

Acttve Add-ins |start Up|

= Isotropic & orthotropic materials S B

= Uniform & non-uniform loads e
[~ &, Solidworks Design Checker

= Multiple restraints Sl
[ [ Solidworks Simulation
C  Solidworks Toolbos

| M [~ ' Solidworks Toolbox Browser
O re e [~ i Solidworks Utilities
I EI Tolanalyst

Hsolidworks Add-ins
[ Autotrace
[~ Solidworks 2D Emulator

[~ Solidwiorks Flow Simulation 2009
[~ Solidworks MTS

[~ Solidworks ¥PS Driver

Hother Add-ins

¥  3Dcontrol

¥  Presentation Studio

[ SustainabilityXpress

oK I Cancel | v
W
e
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Simulation Premium

Stalics

7

EegueERCY,

Buckiing

hemmel

Droepriest

Eatgue

7

Oplimizauoen

7

Pressure
\/essel

-~
EVvent-hased
Vieuen

Noenlinear

r

Eiglerely
Dynamics

COMpPOSsIEs

: SolidWorks Simulation ‘_l_’lps
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ii%ﬁm fhro FEA Fundamentals

- Define and discretize the domain

- Specify approximating function and B.C.

- Create and converge system of equations
- Resolve for quantities of interest
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iﬂ%ﬁm Bhro FEA Fundamentals

. Define the domain
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PENNSTATE

FEA Fundamentals

. Diw the domain

MESH
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PENNSTATE

B
. Discretize using tetrahedrons: 18t order (inear)

= 1 element

» 4 nodes First Order Structural Tetrahedron Element:
4 nodes
12 dof

. .12 x 12 matrix
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g °| FEA Fundamentals

. Discretize using tetrahedrons: 2" order (quadratic)

= ] element

« 10 nodes Second Order Structural Tetrahedron Element:
10 nodes
30 dof

. . 30 x 30 matrix
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iﬁéﬁm o | oA Fundamentals

. Discretize using tetrahedrons: 2"d order

= 1 element

= 10 nodes Second Order Structural Tetrahedron Element:
10 nodes
30 dof

. . 30 x 30 matrix

\ / Curved
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WORLS 5310
o FEA Fundamentals

- Neighboring elements share nodes
= 4 element

= 7 nodes
= DOF ?
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ji,q!sé%m Bro FEA Fundamentals

« Cube
= 12 element
= 9 nodes
= DOF ?
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g FEA Fundamentals

- Specify approximating function
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Big Math
warning

PENNSTATE
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WORLS 5310
g FEA Fundamentals

- Specify approximating function
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FEA Fundamentals

. Specify AR function (2D Triangle, linear)

|t u(f(x, V) =a, +a,X+a,y

EACH ELEMENT
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WORLS 5310
- FEA Fundamentals

©
- Specify approximating function (new node values)

|z u®(x, V) =a, +ax+a,y
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WORLS 5310
- FEA Fundamentals

©
- Specify approximating function (unknown coefficients)

U (x,y) =, +aX+a,y
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WORLS 5310
- FEA Fundamentals

©
- Specify approximating function (current node values)
u®(x,y)=a, +ax+a,y_
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PENNSTATE

FEA Fundamentals

. Specify ANV R AN function (2D Triangle, quadratic)

u(x,y)=oa,+ax+a,y+ 053X2 +a, Xy + a5y2
v(X,y) = :Bo + X+ By + 183)(2 + [, Xy + ,35)/2
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FEA Fundamentals

- Specify approximating function

u(x,y)=a,+ax+a,y
v(X,y) =B, + Bix+ By

- v T v L 1 L
- b
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ii%%m Bro FEA Fundamentals

- Specify approximating function
u(x,y)=a, +a,X+a,y
v(X,Y) =B, + BX+ By
- Equilibrium equations (Hook's Law 2D)
E oJO(ou ov o(ou ov
+ > ( + j+G [ + ]:O
1-v° ox\{ ox oy oy\ oy OxX

O(ou ov E ou ov
G + + | o—+ =0
ox\oy ox) 1l-v ox oy
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g FEA Fundamentals

- Specify approximating function
u(x,y)=a,+ax+a,y

v(X,y) =B, + BX+ B,y

- Equilibrium equations (Hook's Law 2D)

G
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g FEA Fundamentals

- Specify approximating function
u(x,y)=a,+ax+a,y

v(X,y) =B, + BX+ B,y

- Equilibrium equations (Hook's Law 2D)
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AVATAR|
+Li(5_u+@j+gi(a_u+@j:o _
A 1—ofox\ox oy) oylay ox u(x,y) = o, +aX+a,y h

+G£(a_u+@j+ E (,ﬁ_u@):o v(X,Y) =B, + BX+ B,y

!
1
1
!
1
1
i
i
1
1
&
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o FEA Fundamentals

- Specify approximating function
u(x,y)=a,+ax+a,y
v(X,Y) =B, + BX+ Y

. Equilibrium equations (Hook’s Law 2D)

E oO(ou ov O(ou ov
+ > + +G + =0
1-v° ox\ ox oy oy\ oy oOx

o(ou ov E ou ov
G + + ~| v—+ =0
ox\oy ox) 1l-v ox oy

1 L] L
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g FEA Fundamentals

- Specify approximating function
u(x,y)=a,+ax+a,y

v(X,y) =B, + BX+ B,y

- Equilibrium equations (Hook's Law 2D)

2]
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v OX
V

oV oV oV ov ov ov ov oV oV oV

OX OX OX OX OX OX OX OX OX OX
oV oV oV oV oV oV oV oV oV oV

oX oX oX OX OX OX OX OX OX oX
oV oV oV oV oV oV oV oV oV oV

OX OX OX OX OX OX OX OX OX OX
oV oV oV oV oV oV oV oV oV oV

oX oX OX OX OX OX OX OX oX oX
oV ov ov oV oV oV oV oV oV oV

OX OX OX OX OX OX OX OX OX OX )(

oV oV oV oV oV oV oV oV oV oV

OX OX OX OX OX OX OX OX OX OX
oV oV oV ov ov ov ov oV oV oV

OX OX OX OX OX OX OX OX OX OX
oV oV oV oV oV oV oV oV oV oV

oX oX oX OX OX OX OX OX OX oX
oV ov ov oV oV oV oV oV oV oV

OX OX OX OX OX OX OX OX OX OX
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©
- Specify the boundary conditions

Restraint “!’ggﬁgﬁr"‘E@%ﬂﬂﬂ%ﬂﬂﬂﬂﬁuﬁﬂﬂ%ﬂﬁgﬂ%ﬁiﬂ
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WORS 51
pENNs%TE 0 FEA Fundamentals (basic strategy)

- Create and converge system of equations

1) Plug initial mesh geometry into
u(x,y)=a, +ax+a,y

v(X,Y) =B, + BX+ By

2) Plug new node values from 1) into

E Of(ou ov ofou ov
+ >—| —+— |+G—| —+—|=0
1-v° ox\ ox oy oy\oy ox

ofou ov E ou ov
+G—| —+— |+ s|vo—+—|=0
ox\oy ox) l-v OX oy

3) Subtract 1) from 2)

4) Difference 3) drives next iteration
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iﬁéﬁm B0 | tEA Fundamentals

- Resolve for other quantities of interest
= Strain (€)
= Stress (0)

. von Mises Stress: o,, =050, 0, ] + (0, 03] + (05— 03 |
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o Linear elastic stress analysis

- Small displacements with constant b.c.
- Material properties constant (ductile)

Static*

Stress
Ultlmate or Tens”e I i ccocommnnnemmonnnensannenennenasnamnral)

Yield 2

Strain
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©

&

0 Defining a StUdy (fea fundamentals)

Define the type of analysis. (specify approx. function)
Create a study.

Define material for each component.

Define Connections. (b.c.: component-component)
Define Fixtures. (b.c.: reduce model DOF)

Define External Loads. (b.c.: force, pressure, torque)
Define the Mesh. (discretize the domain)

Run the analysis. (solve linear system)

View Results.

Interpret results.
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PENNS%TE Analytical VS. FEA (node)

O-max: KFI xo—n

Stress concentration factor, (flat plate, circular hole, D/W>0.65):

3
K, =2+(1—Ej
W

Normal stress, at hole cross section:

____F
" (W-D)xT

Plate geometry:

D = hole diameter = 70 mm
W = plate width = 100 mm
T = plate thickness = 10 mm

Load:
P = tensile load = 50,000 N

" O e =338 MPa)

DR SRS -« wEN
] 0 ?,l‘%

FEA Solution

P1 (M2 (MPa))

345

a1k
287
250
229
200
171

143
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Egﬁﬁm Flat Plate: vonMises (vpa) VS DOF
Mesh vonMises* DOF
- Coarse 327 7,944
« Default 341 46,728
« Fine 349 281,142
« Default w/ mesh ctrl. 348 52,368

¥ Oy = \/0.5[(01 -0, )2 -+ (02 — 03)2 + (03 —01)2]
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- Default Nodes

won
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° | vonMises (vpa): Default Elements

T Rectangular Plate with Hole

yon Mises (Mimm®2 (MPa))

293

274

| 249



vonMises (MpPa): Fine Nodes

angular Plate with Hole

von Mises (MNAmm2 (MPa))
352

342

B 93
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EN!%HTE B | Consider Symmetry
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w%ﬁ” Simplification: % Symmetry ). ¢
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Simplification: ¥4 Symmetry & 3D

PENNSTATE

von Mises (Mimm"2 (MPa))

258
308.3
280.4
_ 2524
2245
196.5
168.5
140.6
1126
BE.7
Ma. of nodes 1472 oa 7
Mo. of elements 897 :
Mo of DOF 916 0a
Total solution time
— Yield strength; 620.4
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Simplification: ¥4 Symmetry & 2D

von Mises (Mimm2 (MPa))
344.8
J1E.B
2885
_ 2604
2322
2041
176.0
147.8

1197
Solver Message

91.5

Mo. of nodes 326 53.4

MNo. of elerments H37 353
Ma, of DOF

Tatal zolution time

&

— Yield strength: 5204
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g ° vonMises vs. Degree of Freedom

Fine
Mesh

Control Shell
Default

Coarse
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wﬁ"" Flat Plate: vonMises mpa) vs DOF
Mesh vonMises DOF

- Coarse 326 7,902

« Default 340 46,581

« Fine 349 280,218

« Default w/ mesh ctrl. 352 52,197

Y2 Symmetry Shell 347 1,531
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EN!%%E B | - onsider Singularity: L-Bracket pa)

Study Sharp Corner Radius Corner
« Mesh Control 1 76 101
« Mesh Control 2 92 101
« Mesh Control 3 194 101

- Adaptive Mesh : 115
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McMaster-Carr

Eyebol

ts and Eye Nuts

Part Number: 3016T41

$E 8E Each

Type

j |/ Shoulder Type

Thread Type
Material Type
Finish

Steel Type
Thread Size
ok Load Limit
Cimension A
Cimension B
Cimension C
Specifications Met
Furnished With
WARNING

Eyeholts with Muts

Without Shoulder

Fartially Threaded

Steel

Galvanized

Plain Steel

7213

2,100 Ibs.

P

4

o

Mot Rated

One hes nut

Do not exceed work 10ad limits for this iterm. Ary eyebolt
that has been modified from its original design will have a
reduced work load limitand should be discarded.
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°| Work Load Limit Gi
Eﬂiﬁm - ork Load Limit Gilven
Eyebolts and Eye Nuts
Fart Mumber: 3016T41 $6.96 Each
\ Type Evebolts with Muts
|} Shoulder Type Wwithout Shoulder
& © Thread Type Partially Threaded
Material Type Steel
Finish Galvanized
Steel Type Plain Steel
- Thread Size ]
1 | Work Load Limit 2,100 1hs. |
€ Dimension A 1
g Dimension B 4"
Dimension o
Specifications Met Mot Rated
Furnished YWith One hex nut.
WYARMING Do not exceed work oad limits far this item. Any eyebalt
that has been modified from its ariginal design will have a
reduced worlk load limit and should be discarded.
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E?%" Simplify Geometry ¢
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g Suppress nut & thread
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ai!- Eﬁidﬁ o Insert > Curve > Split Line
g Split Line

| % Split Line

|\ I SketchB |

| &3 Face<1l=

[v Single direction
[v' Reverse direction
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o SolidWorks Tutorials

olidworks Simulation Online Tutorial - ol K

Hide Back Home Frint

SolidWorks Simulation Online Tutorials

The lessons present SolidWorks® Simulation functionality in an example-based learning farmat. The verification problems
compare results of SolidWorks Simulation studies to known analytical solutions. Read the Conventions information.

Selections marked with a (Professional) are available with SolidWorks® Simulation Professional and above. Selections marked
with a (Premium) are only available with SolidWorks® Simulation Premium.

— ruoras |

Eroguancy, Buckhng,

Optimization, Drop Test, | ,

! Verification Problems

Frequency Professional) oo, (Premium)




y e A [ S o . i’ v 1 P 5 i . il . y r ¥ i .
b ‘ i L ‘I -, ,‘il'f"?‘" ;1'"5 X o l\ Jh"m_“,_“‘ ‘ - ; L‘{# 'ﬁiﬁ?} ? .

| AR i
0 i F :‘:**_s o =

g SolidWorks Web Help

. http://help.solidworks.com/2010/English/SolidWorks/s
ldworks/Overview/StartPage.htm

%) 2010 SolidWorks Help - welcome to Solidworks Online Help - Mozilla Firefos
He Edt View Hstory Bookmarks Took Help
w c X 4|0 |http:/fhelp.solidworks.comfZO10/Eng\ish/SoI\dWorks/s\dworks,vaervi'ew_/Stari 77D - I?l' ouch y
[cata _sw *gm Pe #s @y [|1s & [ 15[ aw [mawa S 1esse [Pa [Jus w ET I Bl 36 6o L Webzo »
| ] 2010 Solidworks Help - Welc.., | = =
/7 SolidWorks Help
‘Web Help Beta
abaut Web Help Bieta Intraduction = Welcome to SolidWorks Help
Print | Feedback on this topic |I||I|
Welcome to SolidWorks Help
=-Introduction | |
- Welcome ta SolidWorks Help
~.Conwentions Getting Help
L-Access to Help
H-What's New
[]"'Sdm‘msrrafmn Access to Help Lists ways to access help for the SalidWorks® product
e i i and add-ins, as well as hints for searching. See Access |
#-SolidWorks Fundamentals Help.
#-Moving from 20 to 3D
[H-assemblies
[ CircuitWworks What's New Introduces concepts and provides step-by-step example
[#H-Configurations for many new features,
HDEsIgh ChE R, Click Help > What's New > PDF or Help > What's Ne
[H-Design Studies = HTML.
@-Detailing and Drawings
H-DFMKpress
[ DriveWarksxpress Interactive What's Highlights new features in the SolidWorks product and
[#-FloXprass New add-ins,
R Click T naxt to new or changed menu items and
T PropertyManagers,
@ Motion Studies
[#-Parts and Features
&-PhotoView 260 SolidWorks Tutorials Steps you through introductory to advanced examples
B-PhataWorks that teach the functionality of the SolidWorks product ar =
| | S =
| Done. B
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National Agency for Finite Element
Methods and Standards
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E‘? Solidworks Simulation Online Tutorial
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Show Back Home Print

- NAFEMS Benchmarks... B ~imulation NAFEMS
Help > SolidWorks
Simulation > Validation >

This document contains selected NAFEMS benchmarks for linear static problems.

Cylindrical Shell Cylindrical Shell Under
e n C I I l ar S . Under Edge Moment |Pressure

Elliptic Membrane Z-section Cantilever Under

Under Pressure Torsion Bending

Skew Plate Under Hemisphere Under Point

Mormal Pressure Loads

Composite Laminate s

Under Three-point x::‘:i;?emz“m ahell

Bending




RN e o E N AR R R
\ . e M 3

iiq!%%m Bhro FEA Reference

APPLIED FINITE
ELEMENT ANALYSIS

Second Edition

Larry J. Segerlind
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g ° Make Math Fun w/ Direction Field Plotter

. http://www.math.psu.edu/cao/DFD/Dir.html
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Formula Plotter with Integral Curves

TouchPlot
Education
Updated Jan 07, 2010

4093 BUY | v
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Zoom |LiveZoom | Draw | Type | Break |

After togaling ZoomIt you can zoom in with the mouse wheel ar up
and down arrow keys. Exit zoom mode with Escape or by pressing
the right mouse button,

Zoom Toggle: Cirl+1

Show tray icon
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. SolidWorks Simulation

The Design Cycle

Finite Element Method
SolidWorks Simulation
Defining a Simulation Study
Controlling the Mesh
Accessing the Results
Indentifying Singularities
Instructional Examples

Tips and Tricks
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